Search found 14 matches

by tome.talevski
19 Sep 2020, 00:54
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp help!! [SOLVED]

Hmm, I reread what I wrote and it was blatantly wrong. I apologize. To make the drain voltage smaller we need to increase the trimpot resistance, not to decrease it :slap: :slap: :slap: . I'd undo the shorting and replace the trimpot at the first JFET with a 1M potentiometer. If that works for the ...
by tome.talevski
18 Sep 2020, 11:27
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp help!! [SOLVED]

Hmm, I reread what I wrote and it was blatantly wrong. I apologize. To make the drain voltage smaller we need to increase the trimpot resistance, not to decrease it :slap: :slap: :slap: . I'd undo the shorting and replace the trimpot at the first JFET with a 1M potentiometer. If that works for the ...
by tome.talevski
18 Sep 2020, 10:56
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

[...]... however, after passing the multimeter across those two sections you pointed out I think I may have found something.. the yellow circled area and the row above connect according to the MM.. although I can see any bridge or obvious connection on the trace side (I know it might look like ther...
by tome.talevski
18 Sep 2020, 10:11
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

I'd try turning the trimpots all the way clockwise (so they're at full resistance), then I'd short the 10k resistors going to the drains of the JFETs, and then I'd turn s l o w l y (to not endanger the JFETSs) the trimpots counterclockwise until the drain voltage reaches 5V or so. Interesting..! Im...
by tome.talevski
18 Sep 2020, 09:55
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

I'd try turning the trimpots all the way clockwise (so they're at full resistance), then I'd short the 10k resistors going to the drains of the JFETs, and then I'd turn s l o w l y (to not endanger the JFETSs) the trimpots counterclockwise until the drain voltage reaches 5V or so. Interesting..! Im...
by tome.talevski
18 Sep 2020, 09:41
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

The G wrote: 18 Sep 2020, 09:33 Repair the second image link, maybe we can spot something on the trace side.

LATER: Could you provide a link to the vero layout? I didn't find it at a quick glance.

EVEN LATER: Is it viewtopic.php?p=276534#p276534 ?
yep, thats the one :)
by tome.talevski
18 Sep 2020, 09:38
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

Repair the second image link, maybe we can spot something on the trace side. LATER: Could you provide a link to the vero layout? I didn't find it at a quick glance. Here's the trace side and another image off the component side.. https://imgur.com/eYZDbKN https://imgur.com/Xruv1tJ https://imgur.com...
by tome.talevski
18 Sep 2020, 09:28
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

It looks like the trimpots are not doing anything, so I'd check the way they are wired. Unfortunately the second pic (which I presume contains the trace side) is not readable. Thanks for the response. I’ve wired them in as they are shown in the vero layout.. is there something obvious I’ve missed h...
by tome.talevski
18 Sep 2020, 00:27
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Benson Preamp help!! [SOLVED]

Hello, I’ve posted this on the end of the benson preamp thread however just realised it’s probably better suited here. I've attempted this layout on Vero, the layout in the benson thread, and for some reason can't get it to work! Im confident I populated the board correctly and confident that my cut...
by tome.talevski
17 Sep 2020, 11:04
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

You could have fake J201s. They are not being made any more. You really need some test equipment if you are going to DIY and a multimeter is essential. Getting my hands on a multimeter today hopefully so will aim to post all the necessary numbers/values So, ive managed to get a multimeter and get s...
by tome.talevski
17 Sep 2020, 02:41
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

tonyharker wrote: 16 Sep 2020, 10:43 You could have fake J201s. They are not being made any more. You really need some test equipment if you are going to DIY and a multimeter is essential.
Getting my hands on a multimeter today hopefully so will aim to post all the necessary numbers/values
by tome.talevski
16 Sep 2020, 08:44
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

- the only signal/sound I get is when I turn the gain off/CCW and then turn it CW perhaps 5%.. theres a white noise scratch sound. - This sound can me altered by the volume (louder/softer obviously) but also by the treble (sharper/duller)... the bass pot doesn't produce any audible difference. Any ...
by tome.talevski
16 Sep 2020, 02:55
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Re: Benson Preamp [SOLVED]

Hey, thanks for the reply. I have two 50k trimpots installed as per the vero layout. I’ve also used the transistors on the layout - J201. Are you suggesting I reinstall another set of transistors? Thanks again!
by tome.talevski
15 Sep 2020, 23:14
Forum: Pedal Debugging & Troubleshooting Support
Topic: Benson Preamp help!! [SOLVED]
Replies: 23
Views: 268

Benson Preamp help!! [SOLVED]

Moderator: Moved from the Benson preamp thread. Hello - hope its ok to revive an older thread.. I've attempted this layout on Vero and for some reason can't get it to work! Im confident I populated the board correctly and fairly confident that my cuts are clean and that there are no solder bridges ...