Pedal Debugging & Troubleshooting Support

Forum dedicated to helping people debug and troubleshoot non-functional pedals or builds. Please use an clear and informative title, indicating circuit and basic problem. Don't forget to mark the issue as fixed if this is the case.
  • Forum
    Topics
    Posts
    Last post
New Topic
  • Topics
    Replies
    Views
    Last post
  • Bluesbreaker build issue
    by Eightsevenzero »
    1 Replies
    68 Views
    View the latest post Re: Bluesbreaker build issue
    User avatar Last post mauman
  • Rocktek BBD Delay. No Power. Please, I need Troubleshooting Help. Hi Def Photos.
    by fubusmaximus »
    5 Replies
    171 Views
    View the latest post Re: Rocktek BBD Delay. No Po …
    User avatar Last post fubusmaximus
  • DOD FX90 [SOLVED]
    by ericnickel »

      Rating: 0.2%
    13 Replies
    849 Views
    View the latest post Re: DOD FX90
    User avatar Last post CheapPedalCollector
  • Diaz Texas Ranger biasing
    by TheGunn »

      Rating: 0.4%
    20 Replies
    805 Views
    View the latest post Re: Diaz Texas Ranger biasin
    User avatar Last post TheGunn
  • Muted Volume on Overdrive OD11 - see diagrams
    by Numbskull »
    1 Replies
    163 Views
    View the latest post Re: Muted Volume on Overdriv …
    User avatar Last post mauman
  • AionFX L5 Preamp hates Chorus pedals. Rate LFO is audible and annoying
    by Bobb_Lobblaw »

      Rating: 0.2%
    4 Replies
    222 Views
    View the latest post Re: AionFX L5 Preamp hates C …
    User avatar Last post Frank_NH
  • FUZZ FACE DIY DEBUG! I NEED HELP
    by anthrich »
    2 Replies
    294 Views
    View the latest post Re: FUZZ FACE DIY DEBUG! I N …
    User avatar Last post Steve_1160
  • Boss OS-2 Self Oscillating
    by frexle »

      Rating: 0.4%
    19 Replies
    2436 Views
    View the latest post Re: Boss OS-2 Self Oscillati …
    User avatar Last post jimilee
  • Boss Rc-3 Volume pot wiring Help or Schematic
    by Renno »
    3 Replies
    774 Views
    View the latest post Re: Boss Rc-3 Volume pot wir …
    User avatar Last post Fernando JFET
  • MXR Blue Box Assistance/Question [SOLVED]
    by Dr Tony Balls »

      Rating: 0.9%
    5 Replies
    218 Views
    View the latest post Re: MXR Blue Box Assistance/ …
    User avatar Last post Dr Tony Balls
  • MXR Dynacomp (CA3080 Rev E. - 2006) noise fix [SOLVED]
    by lolbou »

      Rating: 0.4%
    0 Replies
    84 Views
    View the latest post MXR Dynacomp (CA3080 Rev E. …
    User avatar Last post lolbou
  • Radial Switchbone JX2 troubleshoot help
    by Matlevo12 »
    1 Replies
    1022 Views
    View the latest post Re: Radial Switchbone JX2 tr …
    User avatar Last post Bengy22
  • EHX POG2 Dry Output not working
    by CJAudio »

      Rating: 0.6%
    5 Replies
    332 Views
    View the latest post Re: EHX POG2 Dry Output not …
    User avatar Last post mauman
  • Testing breadboard circuit w/o amp?
    by thesameguy »

      Rating: 0.6%
    3 Replies
    170 Views
    View the latest post Re: Testing breadboard circu …
    User avatar Last post mauman
  • 1980s TC ELECTRONIC XII Phaser and SCF etc repair - potentiometer knob removal
    by jazzade »

      Rating: 0.6%
    0 Replies
    90 Views
    View the latest post 1980s TC ELECTRONIC XII Phas …
    User avatar Last post jazzade
  • Tremulus Lune - identifying which PCB-maker ('E3'? 'MM'?)
    by clintrubber »
    1 Replies
    178 Views
    View the latest post Re: Tremulus Lune - identify …
    User avatar Last post clintrubber
  • Newbie - boards not working
    by Numbskull »
    1 Replies
    319 Views
    View the latest post Re: Newbie - boards not work …
    User avatar Last post Manfred
  • Need Help Debugging First Fuzz Face Build
    by anthrich »

      Rating: 0.4%
    4 Replies
    300 Views
    View the latest post Re: Need Help Debugging Firs …
    User avatar Last post Bolsyo
  • Baja Sagittarian - switch pop [SOLVED]
    by DjPsychic »

      Rating: 0.2%
    3 Replies
    221 Views
    View the latest post Re: Baja Sagittarian - switc …
    User avatar Last post Intripped
  • Guyatone Multi Octaver PS-009 - only dry sound
    by lbrutti »
    5 Replies
    326 Views
    View the latest post Re: Guyatone Multi Octaver P …
    User avatar Last post lbrutti
  • Ibanez WH10 V3 volume control
    by Giu Lio »
    2 Replies
    656 Views
    View the latest post Re: Ibanez WH10 V3 volume co …
    User avatar Last post Ichabod_Crane
  • Tremolo issues, loud pop in a buffered pedal
    by Hanky- »

      Rating: 0.2%
    1 Replies
    147 Views
    View the latest post Re: Tremolo issues, loud pop …
    User avatar Last post Hanky-
  • EBS Octabass problems (noise when pedal should be inactive).
    by kennedylanduk »
    0 Replies
    216 Views
    View the latest post EBS Octabass problems (noise …
    User avatar Last post kennedylanduk
  • mxr phase 95 mini : 90mode inaudible
    by severthee »
    1 Replies
    659 Views
    View the latest post Re: mxr phase 95 mini : 90mo …
    User avatar Last post Eparker
  • Tonebender MKI: Trouble with Transistors
    by dudecoolhat »
    7 Replies
    325 Views
    View the latest post Re: Tonebender MKI: Trouble …
    User avatar Last post dudecoolhat
New Topic

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum