Pedal Debugging & Troubleshooting Support

Forum dedicated to helping people debug and troubleshoot non-functional pedals or builds. Please use an clear and informative title, indicating circuit and basic problem. Don't forget to mark the issue as fixed if this is the case.
  • Forum
    Topics
    Posts
    Last post
New Topic
  • Topics
    Replies
    Views
    Last post
  • Tube preamp relay click on start up
    by Reachahighernoon »

      Rating: 0.9%
    12 Replies
    210 Views
    View the latest post Re: Tube preamp relay click …
    User avatar Last post Manfred
  • Big Muff clipping switch
    by MateusBorges »
    0 Replies
    25 Views
    View the latest post Big Muff clipping switch
    User avatar Last post MateusBorges
  • Pog original power issue
    by 9 volt »

      Rating: 0.2%
    3 Replies
    128 Views
    View the latest post Re: Pog original power issue
    User avatar Last post phatt
  • 1985 ProCo Rat wiring
    by DjPsychic »

      Rating: 2.2%
    14 Replies
    380 Views
    View the latest post Re: 1985 ProCo Rat wiring
    User avatar Last post Intripped
  • Weird issue with high voltage mosfet buffer [SOLVED]
    by Reachahighernoon »

      Rating: 1.1%
    20 Replies
    325 Views
    View the latest post Re: Weird issue with high vo …
    User avatar Last post Reachahighernoon
  • Rat mod help
    by Mike.Stockb »
    6 Replies
    293 Views
    View the latest post Re: Rat mod help
    User avatar Last post The G
  • Clyde McCoy clone issues [SOLVED]
    by harrisxr650 »

      Rating: 1.1%
    13 Replies
    298 Views
    View the latest post Re: Clyde McCoy clone issues
    User avatar Last post harrisxr650
  • Maestro PS-1A (Help!)
    by aavatech1 »
    12 Replies
    1904 Views
    View the latest post Re: Maestro PS-1A (Help!)
    User avatar Last post aavatech1
  • Footswitch Cut Sound
    by Robin28 »

      Rating: 0.4%
    14 Replies
    375 Views
    View the latest post Re: Footswitch Cut Sound
    User avatar Last post stolen
  • PCB Guitar Mania Master Phaser (Maestro Stage Phaser) Odd Issue
    by rundgrenrules »
    4 Replies
    519 Views
    View the latest post Re: PCB Guitar Mania Master …
    User avatar Last post stolen
  • Joyo Vintage Phase problem?
    by Electricfreedom21 »
    3 Replies
    73 Views
    View the latest post Re: Joyo Vintage Phase probl …
    User avatar Last post CheapPedalCollector
  • Ibanez FL9 turns on, no effect
    by alexpalmowski »

      Rating: 0.2%
    1 Replies
    85 Views
    View the latest post Re: Ibanez FL9 turns on, no …
    User avatar Last post The G
  • Electric Mistress Clone - wont bias
    by rundgrenrules »

      Rating: 0.2%
    9 Replies
    2935 Views
    View the latest post Re: Electric Mistress Clone …
    User avatar Last post Yazoo55
  • Bass preamp (similar to Fender ToneStack pre) - no output
    by simon.blanchaert »
    2 Replies
    1253 Views
    View the latest post Re: Bass preamp (similar to …
    User avatar Last post deltafred
  • Parasit studio - Quantum Defrakulator help? CD4013 issue??
    by tome.talevski »

      Rating: 0.2%
    4 Replies
    1339 Views
    View the latest post Re: Parasit studio - Quantum …
    User avatar Last post tome.talevski
  • Electric Lover Wiring help..
    by Alesek.R »
    1 Replies
    1219 Views
    View the latest post Re: Electric Lover Wiring he …
    User avatar Last post idy
  • Aion FX Gaia MK 1 - No Audio [SOLVED]
    by imwaltraud »

      Rating: 0.9%
    5 Replies
    1548 Views
    View the latest post Re: Aion FX Gaia MK 1 - No A …
    User avatar Last post mauman
  • Strange problem with Boss SD-1
    by InTelejens »
    17 Replies
    1407 Views
    View the latest post Re: Strange problem with Bos …
    User avatar Last post InTelejens
  • Boss CE-2 problems.
    by gurishka »

      Rating: 1.1%
    11 Replies
    801 Views
    View the latest post Re: Boss CE-2 problems.
    User avatar Last post TWSpedals
  • Boss DM-2 ... LED not working despite new LED.
    by soma89 »
    1 Replies
    513 Views
    View the latest post Re: Boss DM-2 ... LED not wo …
    User avatar Last post lolbou
  • Boss DM-2 Agony, MN3205, V3205
    by Crispybacon501 »
    10 Replies
    913 Views
    View the latest post Re: Boss DM-2 Agony, MN3205, …
    User avatar Last post Crispybacon501
  • Tonepad Ross comp build high noise floor
    by danb435 »

      Rating: 0.2%
    7 Replies
    816 Views
    View the latest post Re: Tonepad Ross comp build …
    User avatar Last post phatt
  • Harmonic Percolator Troubleshooting
    by megatrav »
    1 Replies
    583 Views
    View the latest post Re: Harmonic Percolator Trou …
    User avatar Last post mauman
  • EVH Phase 90 Issues
    by Ebulakowski »

      Rating: 0.2%
    9 Replies
    1202 Views
    View the latest post Re: EVH Phase 90 Issues
    User avatar Last post Manfred
  • T-Rex Viper LFO stopped working
    by iefes »

      Rating: 0.2%
    14 Replies
    1079 Views
    View the latest post Re: T-Rex Viper LFO stopped …
    User avatar Last post iefes
New Topic

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum