Pedal Debugging & Troubleshooting Support

Forum dedicated to helping people debug and troubleshoot non-functional pedals or builds. Please use an clear and informative title, indicating circuit and basic problem. Don't forget to mark the issue as fixed if this is the case.
  • Forum
    Topics
    Posts
    Last post
New Topic
  • Topics
    Replies
    Views
    Last post
  • Electric Mistress Clone - wont bias
    by rundgrenrules »

      Rating: 0.2%
    10 Replies
    3417 Views
    View the latest post Re: Electric Mistress Clone …
    User avatar Last post Yupnitski77
  • EHX Deluxe Memory Boy - no feedback
    by puu »

      Rating: 0.2%
    4 Replies
    442 Views
    View the latest post Re: EHX Deluxe Memory Boy - …
    User avatar Last post bc108
  • Roger Mayer Voodoo vibe troubleshooting
    by Ang3lus »
    0 Replies
    154 Views
    View the latest post Roger Mayer Voodoo vibe trou …
    User avatar Last post Ang3lus
  • Boss NS 2: Need help with wiring
    by Pete335 »
    0 Replies
    109 Views
    View the latest post Boss NS 2: Need help with wi …
    User avatar Last post Pete335
  • Mutron Bi-Phase Optical Switch Question
    by pmkipp »

      Rating: 0.2%
    5 Replies
    227 Views
    View the latest post Re: Mutron Bi-Phase Optical …
    User avatar Last post PMowdes
  • Vintage Morley Power Wah Boost Troubleshooting
    by CheapPedalCollector »

      Rating: 0.2%
    13 Replies
    457 Views
    View the latest post Re: Vintage Morley Power Wah …
    User avatar Last post CheapPedalCollector
  • Maestro PS-1A not working
    by Beedoola »
    10 Replies
    2528 Views
    View the latest post Re: Maestro PS-1A not workin
    User avatar Last post Parnellio
  • Orange Rockerverb Preamp J201 Problems
    by KeenVox »
    8 Replies
    1414 Views
    View the latest post Re: Orange Rockerverb Preamp …
    User avatar Last post wormwood
  • Maestro FZ-1a sounds compressed
    by aka180 »
    1 Replies
    210 Views
    View the latest post Re: Maestro FZ-1a sounds com …
    User avatar Last post TWSpedals
  • Rat differences?
    by darrencp »

      Rating: 0.2%
    5 Replies
    267 Views
    View the latest post Re: Rat differences?
    User avatar Last post ggbb
  • Big Muff clipping switch
    by MateusBorges »

      Rating: 0.2%
    2 Replies
    215 Views
    View the latest post Re: Big Muff clipping switch
    User avatar Last post DrAlx
  • Help! Pedalpcb Complex/Friedman Smallbox Probs
    by vmaxvmax »

      Rating: 0.4%
    8 Replies
    366 Views
    View the latest post Re: Help! Pedalpcb Complex/F …
    User avatar Last post Manfred
  • DOD FX20B Stereo Phaser-Not so Stereo
    by acidblue »

      Rating: 0.7%
    3 Replies
    175 Views
    View the latest post Re: DOD FX20B Stereo Phaser- …
    User avatar Last post mauman
  • BAJA Reactor - Effect fading to no sound output.
    by berto25 »
    1 Replies
    180 Views
    View the latest post Re: Effects fading to no sou …
    User avatar Last post mauman
  • Tube preamp relay click on start up
    by Reachahighernoon »

      Rating: 0.9%
    12 Replies
    406 Views
    View the latest post Re: Tube preamp relay click …
    User avatar Last post Manfred
  • Pog original power issue
    by 9 volt »

      Rating: 0.2%
    3 Replies
    229 Views
    View the latest post Re: Pog original power issue
    User avatar Last post phatt
  • 1985 ProCo Rat wiring
    by DjPsychic »

      Rating: 2.2%
    14 Replies
    585 Views
    View the latest post Re: 1985 ProCo Rat wiring
    User avatar Last post Intripped
  • Weird issue with high voltage mosfet buffer [SOLVED]
    by Reachahighernoon »

      Rating: 1.1%
    20 Replies
    775 Views
    View the latest post Re: Weird issue with high vo …
    User avatar Last post Reachahighernoon
  • Rat mod help
    by Mike.Stockb »
    6 Replies
    413 Views
    View the latest post Re: Rat mod help
    User avatar Last post The G
  • Clyde McCoy clone issues [SOLVED]
    by harrisxr650 »

      Rating: 1.1%
    13 Replies
    523 Views
    View the latest post Re: Clyde McCoy clone issues
    User avatar Last post harrisxr650
  • Maestro PS-1A (Help!)
    by aavatech1 »
    12 Replies
    2093 Views
    View the latest post Re: Maestro PS-1A (Help!)
    User avatar Last post aavatech1
  • Footswitch Cut Sound
    by Robin28 »

      Rating: 0.4%
    14 Replies
    541 Views
    View the latest post Re: Footswitch Cut Sound
    User avatar Last post stolen
  • PCB Guitar Mania Master Phaser (Maestro Stage Phaser) Odd Issue
    by rundgrenrules »
    4 Replies
    609 Views
    View the latest post Re: PCB Guitar Mania Master …
    User avatar Last post stolen
  • Joyo Vintage Phase problem?
    by Electricfreedom21 »
    3 Replies
    163 Views
    View the latest post Re: Joyo Vintage Phase probl …
    User avatar Last post CheapPedalCollector
  • Ibanez FL9 turns on, no effect
    by alexpalmowski »

      Rating: 0.2%
    1 Replies
    146 Views
    View the latest post Re: Ibanez FL9 turns on, no …
    User avatar Last post The G
New Topic

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum