Pedal Debugging & Troubleshooting Support

Forum dedicated to helping people debug and troubleshoot non-functional pedals or builds. Please use an clear and informative title, indicating circuit and basic problem. Don't forget to mark the issue as fixed if this is the case.
  • Forum
    Topics
    Posts
    Last post
New Topic
  • Topics
    Replies
    Views
    Last post
  • HELP! Maestro Fuzz-Tone Battery Wire Disconnected
    by PCK »
    7 Replies
    150 Views
    View the latest post Re: HELP! Maestro Fuzz-Tone …
    User avatar Last post FiveseveN
  • Electric Mistress Clone - wont bias
    by rundgrenrules »

      Rating: 0.2%
    10 Replies
    3507 Views
    View the latest post Re: Electric Mistress Clone …
    User avatar Last post Yupnitski77
  • EHX Deluxe Memory Boy - no feedback
    by puu »

      Rating: 0.2%
    4 Replies
    469 Views
    View the latest post Re: EHX Deluxe Memory Boy - …
    User avatar Last post bc108
  • Roger Mayer Voodoo vibe troubleshooting
    by Ang3lus »
    0 Replies
    176 Views
    View the latest post Roger Mayer Voodoo vibe trou …
    User avatar Last post Ang3lus
  • Boss NS 2: Need help with wiring
    by Pete335 »
    0 Replies
    131 Views
    View the latest post Boss NS 2: Need help with wi …
    User avatar Last post Pete335
  • Mutron Bi-Phase Optical Switch Question
    by pmkipp »

      Rating: 0.2%
    5 Replies
    240 Views
    View the latest post Re: Mutron Bi-Phase Optical …
    User avatar Last post PMowdes
  • Vintage Morley Power Wah Boost Troubleshooting
    by CheapPedalCollector »

      Rating: 0.2%
    13 Replies
    471 Views
    View the latest post Re: Vintage Morley Power Wah …
    User avatar Last post CheapPedalCollector
  • Maestro PS-1A not working
    by Beedoola »
    10 Replies
    2553 Views
    View the latest post Re: Maestro PS-1A not workin
    User avatar Last post Parnellio
  • Orange Rockerverb Preamp J201 Problems
    by KeenVox »
    8 Replies
    1439 Views
    View the latest post Re: Orange Rockerverb Preamp …
    User avatar Last post wormwood
  • Maestro FZ-1a sounds compressed
    by aka180 »
    1 Replies
    225 Views
    View the latest post Re: Maestro FZ-1a sounds com …
    User avatar Last post TWSpedals
  • Rat differences?
    by darrencp »

      Rating: 0.2%
    5 Replies
    292 Views
    View the latest post Re: Rat differences?
    User avatar Last post ggbb
  • Big Muff clipping switch
    by MateusBorges »

      Rating: 0.2%
    2 Replies
    230 Views
    View the latest post Re: Big Muff clipping switch
    User avatar Last post DrAlx
  • Help! Pedalpcb Complex/Friedman Smallbox Probs
    by vmaxvmax »

      Rating: 0.4%
    8 Replies
    380 Views
    View the latest post Re: Help! Pedalpcb Complex/F …
    User avatar Last post Manfred
  • DOD FX20B Stereo Phaser-Not so Stereo
    by acidblue »

      Rating: 0.7%
    3 Replies
    189 Views
    View the latest post Re: DOD FX20B Stereo Phaser- …
    User avatar Last post mauman
  • BAJA Reactor - Effect fading to no sound output.
    by berto25 »
    1 Replies
    194 Views
    View the latest post Re: Effects fading to no sou …
    User avatar Last post mauman
  • Tube preamp relay click on start up
    by Reachahighernoon »

      Rating: 0.9%
    12 Replies
    421 Views
    View the latest post Re: Tube preamp relay click …
    User avatar Last post Manfred
  • Pog original power issue
    by 9 volt »

      Rating: 0.2%
    3 Replies
    244 Views
    View the latest post Re: Pog original power issue
    User avatar Last post phatt
  • 1985 ProCo Rat wiring
    by DjPsychic »

      Rating: 2.2%
    14 Replies
    607 Views
    View the latest post Re: 1985 ProCo Rat wiring
    User avatar Last post Intripped
  • Weird issue with high voltage mosfet buffer [SOLVED]
    by Reachahighernoon »

      Rating: 1.1%
    20 Replies
    820 Views
    View the latest post Re: Weird issue with high vo …
    User avatar Last post Reachahighernoon
  • Rat mod help
    by Mike.Stockb »
    6 Replies
    430 Views
    View the latest post Re: Rat mod help
    User avatar Last post The G
  • Clyde McCoy clone issues [SOLVED]
    by harrisxr650 »

      Rating: 1.1%
    13 Replies
    545 Views
    View the latest post Re: Clyde McCoy clone issues
    User avatar Last post harrisxr650
  • Maestro PS-1A (Help!)
    by aavatech1 »
    12 Replies
    2111 Views
    View the latest post Re: Maestro PS-1A (Help!)
    User avatar Last post aavatech1
  • Footswitch Cut Sound
    by Robin28 »

      Rating: 0.4%
    14 Replies
    564 Views
    View the latest post Re: Footswitch Cut Sound
    User avatar Last post stolen
  • PCB Guitar Mania Master Phaser (Maestro Stage Phaser) Odd Issue
    by rundgrenrules »
    4 Replies
    625 Views
    View the latest post Re: PCB Guitar Mania Master …
    User avatar Last post stolen
  • Joyo Vintage Phase problem?
    by Electricfreedom21 »
    3 Replies
    179 Views
    View the latest post Re: Joyo Vintage Phase probl …
    User avatar Last post CheapPedalCollector
New Topic

Forum permissions

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum