Guyatone - TD-X Tube Echo (Flip Series)  [schematic]

All about modern commercial stompbox circuits from Electro Harmonix over MXR, Boss and Ibanez into the nineties.
Post Reply
User avatar
GuitarManiac32
Information
Posts: 33
Joined: 19 Nov 2007, 19:37
Completed builds: BSIAB2, Zen Drive, Geoffrey Teese Picture wah, Catalinbread Dirty Little Secret, Octavia, A LOT OF FUZZ PEDALS, Neovibe, Barber Tone Press-alike, few guitar amps (Soldano SLO 100, Dumble ODS, Fender Super Reverb, Marshall JTM-45, Fender Champ)
Location: Lahti, Finland
Has thanked: 9 times
Been thanked: 1 time

Post by GuitarManiac32 »

Hi!

I promised to put the schematic here already some days ago, but didn´t have enough time. So, here it is... if there is a thread about this pedal, moderators could move the schematic there or something.
Attachments
TD-X_EPK-466.pdf
(1.19 MiB) Downloaded 715 times

User avatar
Marko9801
Information
Posts: 36
Joined: 25 Dec 2008, 16:46

Post by Marko9801 »

Hi, I've just received this pedal, used... It obviously has a problem, the echo sound is clipping to the extreme... I don't mean the slight distorting of the delay signal that is normal, but simply clipping too loud...
When analog knob is anywhere over 0 it is distorting, but even "Tape" knob clips too much on the low E string...

What is most common for this problem? Faulty tube or should I return it today? I've tried with 2 different DC12V adaptors with the same clipping result... Please help, this pedal is too expensive too be this lousy sounding! :cry:

User avatar
Marko9801
Information
Posts: 36
Joined: 25 Dec 2008, 16:46

Post by Marko9801 »

Marko9801 wrote:Hi, I've just received this pedal, used... It obviously has a problem, the echo sound is clipping to the extreme... I don't mean the slight distorting of the delay signal that is normal, but simply clipping too loud...
When analog knob is anywhere over 0 it is distorting, but even "Tape" knob clips too much on the low E string...

What is most common for this problem? Faulty tube or should I return it today? I've tried with 2 different DC12V adaptors with the same clipping result... Please help, this pedal is too expensive too be this lousy sounding! :cry:
Nevermind, it wasn't the pedal it was my 10W solid state amp... Played it on three other amps, tube amps, with no problem...

User avatar
nyklus
Information
Posts: 2
Joined: 23 Dec 2012, 19:10

Post by nyklus »

hello, can you repost this schematic? i can find it anywhere.
thanks

User avatar
Fredenando
Breadboard Brother
Information
Posts: 130
Joined: 20 Mar 2010, 11:37
Has thanked: 458 times
Been thanked: 88 times

Post by Fredenando »


User avatar
sadrew
Breadboard Brother
Information
Posts: 148
Joined: 08 Apr 2008, 08:45
Location: London UK
Has thanked: 10 times
Been thanked: 14 times

Post by sadrew »

please repost?

User avatar
madmotoscooter
Information
Posts: 2
Joined: 04 Mar 2011, 03:18

Post by madmotoscooter »

Bump. Please re-post.

User avatar
Fredenando
Breadboard Brother
Information
Posts: 130
Joined: 20 Mar 2010, 11:37
Has thanked: 458 times
Been thanked: 88 times

Post by Fredenando »


User avatar
Goldsoundz
Information
Posts: 21
Joined: 29 Sep 2011, 05:26

Post by Goldsoundz »

i love this pedal, but I get the repeats bleeding through to the bypassed clean signal when they're oscillating, and the indicated led starts to light up a bit. Any thoughts?

User avatar
Goldsoundz
Information
Posts: 21
Joined: 29 Sep 2011, 05:26

Post by Goldsoundz »

The schem and layout dont seem have component values. Also, does anyone know what the delay chip is in this thing (and any other delays that might use it)?

User avatar
toby2
Information
Posts: 3
Joined: 30 Mar 2012, 03:28

Post by toby2 »

Does anyone out there have a schematic for this pedal ? Someone used the wrong power supply on mine and fried a chip or a transistor . A schematic for this pedal would be really help in troubleshooting this old effector . Thanks for your time !

User avatar
guitarist
Information
Posts: 10
Joined: 03 Jan 2010, 11:54

Post by guitarist »

Hi there, did anyone find a schematic for this series as of yet?

thanks.

Post Reply