DIYLC 3.x - Can't Open File After Importing .JPG File

Digital tools for electronic work: software for pcb design, schematic drawing, circuit simulation, parts inventory tools, ...
Post Reply
u2-1980
Posts: 1
Joined: 26 Mar 2012, 04:10

Post by u2-1980 »

I'm using DIYLC 3.1.0 (and also tried 3.6.0) beta and having a strange problem. I'm using the "Image" function under the "MISC" tab. I imported a couple of .JPG files of components that were not in the library. Seemed to work fine. When I saved the file, closed DIYLC, then tried to open the file the next time, DIYLC gave me the following error:

"Could not open file [my file path and name.diy]. Check the log for details."

In the log, the first few lines where the problem occurs look like this.
NOTE: I even tried to open and create a new file in 3.6.0 and just insert a couple of images. The first image I inserted was 176x82 pixels, so I know it's having trouble opening that file. The file exists right where I browsed to it when creating the file. MY test project was saved as "test.diy" as you can see below. Also, I tried using a different image that was a different size and it failed too, so it's not the image itself. The files are 96dpi 24bit color .JPG's.


22:22:48,224 DEBUG [SwingWorker-pool-1-thread-2] ActionFactory - Opening from C:\Users\user\Desktop\Circuit Stuff\diylc-3.1.0-beta\test.diy
22:22:48,224 INFO [SwingWorker-pool-1-thread-2] Presenter - loadProjectFromFile(C:\Users\user\Desktop\Circuit Stuff\diylc-3.1.0-beta\test.diy)
22:22:48,224 INFO [SwingWorker-pool-1-thread-2] ProjectFileManager - loadProjectFromFile(C:\Users\user\Desktop\Circuit Stuff\diylc-3.1.0-beta\test.diy)
22:22:48,299 DEBUG [SwingWorker-pool-1-thread-2] IconImageConverter - Reading image from file: 176x82
22:22:48,350 WARN [SwingWorker-pool-1-thread-2] ProjectFileManager - Could not open with the new xStream, trying the old one
22:22:48,372 DEBUG [SwingWorker-pool-1-thread-2] IconImageConverter - Reading image from file: 176x82
22:22:48,410 ERROR [SwingWorker-pool-1-thread-2] Presenter - Could not load file
com.thoughtworks.xstream.converters.ConversionException: null : null
---- Debugging information ----
cause-exception : java.lang.NullPointerException
cause-message : null
class : org.diylc.core.Project
required-type : javax.swing.ImageIcon
path : /org.diylc.core.Project/components/org.diylc.components.misc.Image/image


Any suggestions? I'm stumped. I'm running on Win7 64bit. Java is up to date. Other project files (no images added to them) open fine.

sinner
Old Solderhand
Posts: 4809
Joined: 06 Nov 2008, 18:16
Location: ...no more
Has thanked: 1111 times
Been thanked: 954 times

Post by sinner »

I had the same problem (not only related to image import) before, but Bancika (software creator) seems to fix it in newer version.

Email your problem with project file and log text attached to bancika [at] gmail.com

He will help you faster :)

Good luck

User avatar
bluebunny
Posts: 4
Joined: 05 Dec 2011, 19:50
Location: UK
Been thanked: 1 time

Post by bluebunny »

I had this problem too. When I inspected the .diy file, it had been truncated in the middle of the data for an embedded graphic. I wasn't able to fix up the XML to make it work again... :(

Post Reply