FORUM UPGRADES DONE: Friday 8th MAY 2020 09.00 CET - Saturday 9th 13.00 CET

Have a look here for general information about the forum, rules and announcements.
User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

Hi all,

It's been long overdue but I've set up the HTTPS configuration, so freestompboxes is now running on a secure server. Still some bugs:
  • logo is still missing
  • most of the imagesets seem to have gone missing
  • some cleaning and updating to be done
  • we were still loitering on PHPBB version 3.0.10 while version 3.3. has been released recently
Don't hesitate to communicate any problems, but please mention your setup (computer and browser)
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

I'm using this thread to register what I did, in case shit goes south (which it always does) and it's been a while

imageset problem https://www.phpbb.com/community/viewtopic.php?t=2208346
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

Ben N
Resistor Ronker
Information
Posts: 380
Joined: 12 Dec 2008, 03:34
my favorite amplifier: Ampeg J12D Jet
Location: Israel
Has thanked: 41 times
Been thanked: 17 times

Post by Ben N »

I noticed some changes. Thanks, Modman, for all the hard work and dedication.

User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

Thanks to forum member Gabi we are rockin' on with our bad pedal tracin' selves again!

So we are running a SSL security certificate (which probably channel all our personal information straight to the NSA)
The youtube embedding function has been fixed: just put in a url



and format it with the youtube button above the post window

Code: Select all

[youtube]https://www.youtube.com/watch?v=-GJ8-m01sNM[/youtube]
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

User avatar
bajaman
Old Solderhand
Information
Posts: 4410
Joined: 26 Jun 2007, 21:18
Location: New Brighton, Christchurch, NZ
Has thanked: 467 times
Been thanked: 1708 times

Post by bajaman »

:thumbsup
cheers
bajaman
be kind to all animals - especially human beings

User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

bajaman wrote::thumbsup
cheers
bajaman
the /bajaman folder is not accessible yet and needs to be whitelisted -- just discovered this a minute ago.
will look into that tomorrow.

Any issues anybody is experiencing, please do report them here.
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

Manfred
Transistor Tuner
Information
Posts: 1136
Joined: 04 Apr 2009, 23:42
Has thanked: 1103 times
Been thanked: 707 times

Post by Manfred »

Hi Modman,

thanks for all your work to keep the forum up and running.

User avatar
plush
Resistor Ronker
Information
Posts: 427
Joined: 08 Dec 2015, 09:29
Location: Moscow, Evil Russia
Has thanked: 28 times
Been thanked: 96 times

Post by plush »

Niticed occasional error during login - SSL_ERROR_RX_RECORD_TOO_LONG

Bside2234
Solder Soldier
Information
Posts: 247
Joined: 30 Jul 2007, 19:35
Location: Kennewick, WA
Has thanked: 4 times
Been thanked: 72 times

Post by Bside2234 »

plush wrote:Niticed occasional error during login - SSL_ERROR_RX_RECORD_TOO_LONG
I got this today also. PC/Firefox. It wouldn't load in the current window due to this error but I opened another tab and it seemed to work fine.

Edit: The second I hit submit the error came back:
Secure Connection Failed

An error occurred during a connection to freestompboxes.org:80. SSL received a record that exceeded the maximum permissible length.

Error code: SSL_ERROR_RX_RECORD_TOO_LONG

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

Double edit: It seems to happen every time I hit SUBMIT. It goes to a "Your message has been edited" redirect screen that seems fine but the redirect from that is throwing the error.

Manfred
Transistor Tuner
Information
Posts: 1136
Joined: 04 Apr 2009, 23:42
Has thanked: 1103 times
Been thanked: 707 times

Post by Manfred »

I got this today too.
I cannot login, the same happend using the Opera browser.
It works using the Microsoft Edge browser, but all works dead slow.

Ben N
Resistor Ronker
Information
Posts: 380
Joined: 12 Dec 2008, 03:34
my favorite amplifier: Ampeg J12D Jet
Location: Israel
Has thanked: 41 times
Been thanked: 17 times

Post by Ben N »

Ah, good to have you back, good to be back. (Out all day, using Chrome.)

User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

thanks for the feedback everybody, please keep it freely flowing.

There was a server breakdown at the Swedish meatball server company... from which we haven't fully recovered yet; the forum seems slow.
Anyways, forum software updates are being tested by Gabi offline.
We will switch gears to PHP 7.x and the latest incarnation of the forum software phpbb 3.3. which will definitely make the forum much faster. We have to make the forum more accessible for mobile devices, we also need better attachment management, automatic resizing of images and if this sever company doesn't clear out its act, we may have to upgrade server plan or even move servers...

the list is endless, because here's where the you guys have to chime in on forum functionality you would like to see implemented.

Johan
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

User avatar
Fender3D
Cap Cooler
Information
Posts: 531
Joined: 08 Aug 2009, 02:40
Location: Helltaly
Has thanked: 104 times
Been thanked: 137 times

Post by Fender3D »

Thanks for your efforts in keeping this web site alive and ass-kicking, Modman

User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

At last we are back to normal speed...

Board seems stable and loading ok with SSL in place.
Installation of the upgraded forum software will happen soon, testing is being done to make sure we get no surprises.
I'll announce any downtime when it's clear when the upgrade is going to happen.
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

User avatar
Intripped
Cap Cooler
Information
Posts: 564
Joined: 25 Aug 2009, 01:03
Location: Italy
Has thanked: 700 times
Been thanked: 220 times

Post by Intripped »

There's a problem if you use the "mark forums read" link in the board index page
If you wait for the automatic return to the index page, an error occurs:

An error occurred during a connection to http://www.freestompboxes.org:80. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

Thanks modman!

User avatar
turbofeedus
Breadboard Brother
Information
Posts: 65
Joined: 17 Feb 2012, 04:08
Has thanked: 24 times
Been thanked: 39 times

Post by turbofeedus »

Intripped wrote:There's a problem if you use the "mark forums read" link in the board index page
If you wait for the automatic return to the index page, an error occurs:

An error occurred during a connection to http://www.freestompboxes.org:80. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG

Thanks modman!
The problem is in the forwarding. Port 80 is http, but the SSL is now https (port 443). If you change the "80" to "443", the page should load correctly.

User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

turbofeedus wrote:
Intripped wrote:There's a problem if you use the "mark forums read" link in the board index page
If you wait for the automatic return to the index page, an error occurs:
An error occurred during a connection to http://www.freestompboxes.org:80. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG
Thanks modman!
The problem is in the forwarding. Port 80 is http, but the SSL is now https (port 443). If you change the "80" to "443", the page should load correctly.
Yes, port number was 443 but that didn't solve the loading issue, so removed it. Seemed to work better, but still had the same porting issue. But SSL record too long is a specific Firefox bug it seems.
https://www.thesslstore.com/blog/ssl_er ... _too_long/

still testing
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

Bside2234
Solder Soldier
Information
Posts: 247
Joined: 30 Jul 2007, 19:35
Location: Kennewick, WA
Has thanked: 4 times
Been thanked: 72 times

Post by Bside2234 »

Firefox/PC

I actually get this with every button I tried to push. Not just what I mentioned previously:
Secure Connection Failed

An error occurred during a connection to freestompboxes.org:80. SSL received a record that exceeded the maximum permissible length.

Error code: SSL_ERROR_RX_RECORD_TOO_LONG

AND

The links in the email notifications I get don't work. All of them do this:

The connection has timed out

The server at freestompboxes.org is taking too long to respond.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

User avatar
modman
a d m i n
Information
Posts: 4617
Joined: 19 Jun 2007, 16:57
Has thanked: 3478 times
Been thanked: 742 times

Post by modman »

Yes, if loading gets stuck on a 'return' page, you will probably see :80 in the url.
implemented some changes earlier today, but forgot to flush the cache...

should be better now. If not, before anything else, clear your pc's cache
Keep the error messages coming...
Please, support freestompboxes.org on Patreon for just 1 pcb per year! Or donate directly through PayPal

User avatar
Intripped
Cap Cooler
Information
Posts: 564
Joined: 25 Aug 2009, 01:03
Location: Italy
Has thanked: 700 times
Been thanked: 220 times

Post by Intripped »

modman wrote:
turbofeedus wrote:
Intripped wrote:There's a problem if you use the "mark forums read" link in the board index page
If you wait for the automatic return to the index page, an error occurs:
An error occurred during a connection to http://www.freestompboxes.org:80. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG
Thanks modman!
The problem is in the forwarding. Port 80 is http, but the SSL is now https (port 443). If you change the "80" to "443", the page should load correctly.
Yes, port number was 443 but that didn't solve the loading issue, so removed it. Seemed to work better, but still had the same porting issue. But SSL record too long is a specific Firefox bug it seems.
https://www.thesslstore.com/blog/ssl_er ... _too_long/

still testing
It works now, I get no more the error message (I use Firefox mobile)

Post Reply