Sekova - Fuzz ( FA-II , Apollo , Crestwood )  [schematic]

Discussion regarding early stompbox technology: 1960-1975 Please keep discussion focused and contribute what info you have...
dukeofearl
Posts: 5
Joined: 16 Feb 2019, 18:20
Been thanked: 4 times

Post by dukeofearl »

I'm guessing the big one labeled 224m50 is 224nf 50v, so i should look for .22uf. open to suggestions as to what type. and if anyone has a guess on the other two. i've done recapping before but never on a guitar pedal.

according to the diagram posted above, the little green fuzzy one would be C10, so 0.001uF - sound right? film, ceramic?

grizzlytone
Breadboard Brother
Posts: 68
Joined: 14 Sep 2008, 14:34
Has thanked: 27 times
Been thanked: 79 times

Post by grizzlytone »

dukeofearl wrote:I'm guessing the big one labeled 224m50 is 224nf 50v, so i should look for .22uf. open to suggestions as to what type. and if anyone has a guess on the other two. i've done recapping before but never on a guitar pedal.

according to the diagram posted above, the little green fuzzy one would be C10, so 0.001uF - sound right? film, ceramic?
224 = 220000pF = 220nF = 0.22uF

dukeofearl
Posts: 5
Joined: 16 Feb 2019, 18:20
Been thanked: 4 times

Post by dukeofearl »

thanks, i'll replace that one and see if it works. maybe the fuzzy ones are ok?

dukeofearl
Posts: 5
Joined: 16 Feb 2019, 18:20
Been thanked: 4 times

Post by dukeofearl »

well i replaced that one cap and it's still not working. any other ideas?

george giblet
Solder Soldier
Posts: 176
Joined: 30 Dec 2008, 18:27
Has thanked: 79 times
Been thanked: 100 times

Post by george giblet »

well i replaced that one cap and it's still not working. any other ideas?
DC voltages would be good.

It's possible the electros are stuff.
Are the leads on that smaller green-cap OK ?

drewl
Breadboard Brother
Posts: 105
Joined: 11 Feb 2010, 15:56
Been thanked: 5 times

Post by drewl »

Is the volume supposed to be pretty low on these?

The output filter really kills the signal.

drewl
Breadboard Brother
Posts: 105
Joined: 11 Feb 2010, 15:56
Been thanked: 5 times

Post by drewl »

Ah, read the Tone Machines write up and this is normal.

This one is a 9v version in very good condition.

Post Reply