EHX Deluxe Memory Boy - no feedback

Forum dedicated to helping people debug and troubleshoot non-functional pedals or builds. Please use an clear and informative title, indicating circuit and basic problem. Don't forget to mark the issue as fixed if this is the case.
Post Reply
User avatar
puu
Information
Posts: 5
Joined: 20 Nov 2014, 18:05
Location: Finland
Been thanked: 1 time

Post by puu »

Hello, my first post!

I got a Deluxe Memory Boy that does not replay feedbacks at all. The PCB is Rev D as seen in the picture below.

I measured BBD clock signals in the breakaway board (detachable board containing trimmers and BBDs) with oscilloscope. They looked very distorted and amplitude seemed too low. Other clock's waveform seemed more like triangle than square.

Then I detached breakaway board and measured clock signals, and they looked very nice square wave. So, I think that something in the breakaway board is distorting clock signals so BBDs do not work. What can it be?

Does someone have schematics for this?

Image

User avatar
puu
Information
Posts: 5
Joined: 20 Nov 2014, 18:05
Location: Finland
Been thanked: 1 time

Post by puu »

Here is clocks' waveform when the breakaway board is not connected:
http://koti.kapsi.fi/~puu/stomp/deluxe_ ... cks_ok.png

...and here when the board is connected:
http://koti.kapsi.fi/~puu/stomp/deluxe_ ... s_dist.png

I removed all BBD chips from their sockets, but it did not make clock waveform any better. I also resoldered every solder joint in the breakaway board but it did not help.

User avatar
puu
Information
Posts: 5
Joined: 20 Nov 2014, 18:05
Location: Finland
Been thanked: 1 time

Post by puu »

Okay, it seems that HEF4011BT (Quad 2-input NAND gate) is broken-down. I assume that it generates clock signals for all 4 BBD:s from MCU's clocks. I removed it from the back of the breakaway board, and now clock signals are nice square wave. So I'll order a new one and let's see if it starts to function.

User avatar
puu
Information
Posts: 5
Joined: 20 Nov 2014, 18:05
Location: Finland
Been thanked: 1 time

Post by puu »

FIXED!

Today i got new HEF4011BT quad NAND. I soldered it into the board and now I can get the echo out. 8)
Here is some photos that i shot inside:
http://koti.kapsi.fi/~puu/stomp/deluxe_memory_boy/

User avatar
bc108
Breadboard Brother
Information
Posts: 78
Joined: 04 May 2017, 15:39
my favorite amplifier: BE100
Has thanked: 34 times
Been thanked: 4 times

Post by bc108 »

Love my DMB.
Nice gutshots.. thanks for that.
The only thing I would like to improve, is the Feedback knob sweep. It is very sensible from about 1 to 3 o o'clock. Before it doesn't change much, and at 3 or after start the crazy oscillation.
I've seen that theres a B5K pot there.. maybe som C5K pot could make the sweep more dinamic?

Old thread bump.. sorry

Post Reply