Reversed battery by accident in Aqua Puss - help needed

Frequent questions about dead or faulty pedals. Whether you repair, mod or build pedals, debugging is important. Threads about general debugging problems irrespective of the circuit involved...
Post Reply
TB-AV
Posts: 5
Joined: 27 Mar 2009, 22:42

Post by TB-AV »

I mis-wired a battery clip to power the AquaPuss build. I simply wired a plug to a 9v batt. and mistakenly put + on tip.

The board was complete with transistors and all other parts but no chips. I got a dead short and didn't notice it until the battery got quite hot.

So I finally figured out what I did and corrected the battery polarity. Problem is I still have a short and battery still gets hot.

Any idea which parts might have likely failed so I can narrow things down?

Thanks.

Oh, also I have checked and rechecked several times for mis-wiring, stray solder, incorrect polarity of caps, diodes, etc. All lots correct and clean.

TB

User avatar
lolbou
Old Solderhand
Posts: 2752
Joined: 18 Nov 2008, 22:38
Has thanked: 295 times
Been thanked: 189 times

Post by lolbou »

If the battery short outside the circuit (in the clip), then no parts should have burn...

Desolder the clip, and check for any short between the two tracks (+9V and GND) with a multimeter. By the way, check your battery clip for shots too...

Let us know!
- Are you a mod or a rocker?
- Uh, no, I'm a mocker.

TB-AV
Posts: 5
Joined: 27 Mar 2009, 22:42

Post by TB-AV »

Thanks, I got it taken care of. the only part to get damaged was a diode(D2). It's up and running now.

TB

Post Reply