Ibanez AD-80 Repair

Forum dedicated to helping people debug and troubleshoot non-functional pedals or builds. Please use an clear and informative title, indicating circuit and basic problem. Don't forget to mark the issue as fixed if this is the case.
Post Reply
User avatar
DjPsychic
Breadboard Brother
Information
Posts: 147
Joined: 07 Feb 2020, 21:35
Has thanked: 85 times
Been thanked: 48 times

Post by DjPsychic »

Hi there,

Working on an Ibanez AD-80 (narrow box) currently. I’m in the process of replacing a broken diode and just want to make sure this the right part on the schem? Going to replace with a 1N4004.
ibanez1.jpeg
ibanez2.jpeg
Link to schematic:
https://experimentalistsanonymous.com/d ... 20AD80.pdf

The pedal powered on (led), but passed no signal. There was one cap that had broke lose from the board and this diode. I re-soldered the cap, and will replace the diode. hopefully this brings it back to life!

User avatar
Fender3D
Cap Cooler
Information
Posts: 573
Joined: 08 Aug 2009, 02:40
Location: Helltaly
Has thanked: 122 times
Been thanked: 153 times

Post by Fender3D »

Sadly the pedal should work even without the diode...

User avatar
DjPsychic
Breadboard Brother
Information
Posts: 147
Joined: 07 Feb 2020, 21:35
Has thanked: 85 times
Been thanked: 48 times

Post by DjPsychic »

Fender3D wrote: 06 Jun 2023, 11:18 Sadly the pedal should work even without the diode...
Dang, I had a feeling. Is it safe to run without the diode?

User avatar
Manfred
Tube Twister
Information
Posts: 1976
Joined: 04 Apr 2009, 23:42
Has thanked: 1698 times
Been thanked: 1376 times

Post by Manfred »

Working on an Ibanez AD-80 (narrow box) currently. I’m in the process of replacing a broken diode and just want to make sure this the right part on the schem? Going to replace with a 1N4004.
The 1N4001 works in this application, I think the defective diode was a small signal diode.

User avatar
DjPsychic
Breadboard Brother
Information
Posts: 147
Joined: 07 Feb 2020, 21:35
Has thanked: 85 times
Been thanked: 48 times

Post by DjPsychic »

Digging deeper, that can’t be good :scratch:

Notice the cut in the trace left side. Is that wire a attempted repair or stock I wonder?
FA37DBA7-1CD2-48DF-9E57-1E98608B7AAB.jpeg
Full board for reference. (I disconnected wire to switch to pull board out, that’s why there’s a missing link - right side)
1122E00A-55DF-41C5-9A35-F2501D759FFF.jpeg
Board flipped over. Cut is under the MN3005
18CA8AB5-465F-431F-AAC3-3A7FEF2BE311.jpeg

User avatar
CheapPedalCollector
Resistor Ronker
Information
Posts: 399
Joined: 19 Oct 2020, 15:15
Has thanked: 452 times
Been thanked: 149 times

Post by CheapPedalCollector »

A wire is off, the reverse polarity probably cooked some of the caps. Other things should be fine, except maybe the MN3005, but you can still get Cool Audio reproductions of those.

User avatar
DjPsychic
Breadboard Brother
Information
Posts: 147
Joined: 07 Feb 2020, 21:35
Has thanked: 85 times
Been thanked: 48 times

Post by DjPsychic »

Replaced the broken diode, and resoldered one of the green film caps and it works thankfully!

Post Reply